pkgcond: Classed Error and Warning Conditions

This provides utilities for creating classed error and warning conditions based on where the error originated.

Version: 0.1.1
Depends: R (≥ 3.5.0)
Imports: assertthat, methods
Suggests: covr, testthat
Published: 2021-04-28
Author: Andrew Redd [aut, cre], R Documentation Task Force [aut]
Maintainer: Andrew Redd <Andrew.Redd at hsc.utah.edu>
BugReports: https://github.com/RDocTaskForce/pkgcond/issues
License: GPL-2
URL: https://github.com/RDocTaskForce/pkgcond
NeedsCompilation: no
Language: en-US
Materials: README NEWS
CRAN checks: pkgcond results

Downloads:

Reference manual: pkgcond.pdf
Package source: pkgcond_0.1.1.tar.gz
Windows binaries: r-devel: pkgcond_0.1.1.zip, r-release: pkgcond_0.1.1.zip, r-oldrel: pkgcond_0.1.1.zip
macOS binaries: r-release (arm64): pkgcond_0.1.1.tgz, r-release (x86_64): pkgcond_0.1.1.tgz, r-oldrel: pkgcond_0.1.1.tgz
Old sources: pkgcond archive

Reverse dependencies:

Reverse imports: aRchi, viewshed3d

Linking:

Please use the canonical form https://CRAN.R-project.org/package=pkgcond to link to this page.