CRAN Package Check Results for Package rGEDI

Last updated on 2021-09-26 16:49:26 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.11 28.78 169.01 197.79 WARN
r-devel-linux-x86_64-debian-gcc 0.1.11 22.42 126.89 149.31 WARN
r-devel-linux-x86_64-fedora-clang 0.1.11 256.42 NOTE
r-devel-linux-x86_64-fedora-gcc 0.1.11 127.67 NOTE
r-devel-windows-x86_64 0.1.11 25.00 6.00 31.00 ERROR
r-devel-windows-x86_64-gcc10-UCRT 0.1.11 NOTE
r-patched-linux-x86_64 0.1.11 27.25 157.49 184.74 WARN
r-patched-solaris-x86 0.1.11 258.10 ERROR
r-release-linux-x86_64 0.1.11 29.64 157.51 187.15 WARN
r-release-macos-arm64 0.1.11 ERROR
r-release-macos-x86_64 0.1.11 ERROR
r-release-windows-ix86+x86_64 0.1.11 82.00 258.00 340.00 NOTE
r-oldrel-macos-x86_64 0.1.11 ERROR
r-oldrel-windows-ix86+x86_64 0.1.11 62.00 251.00 313.00 NOTE

Check Details

Version: 0.1.11
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:21: warning: The macro `AC_TRY_RUN' is obsolete.
     configure.ac:21: You should run autoupdate.
     ./lib/autoconf/general.m4:2997: AC_TRY_RUN is expanded from...
     inst/m4/gsl.m4:5: AX_PATH_GSL is expanded from...
     configure.ac:21: the top level
     configure.ac:21: warning: The macro `AC_TRY_LINK' is obsolete.
     configure.ac:21: You should run autoupdate.
     ./lib/autoconf/general.m4:2920: AC_TRY_LINK is expanded from...
     inst/m4/gsl.m4:5: AX_PATH_GSL is expanded from...
     configure.ac:21: the top level
     configure.ac:100: warning: AC_OUTPUT should be used without arguments.
     configure.ac:100: You should run autoupdate.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.1.11
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-windows-ix86+x86_64

Version: 0.1.11
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘rgdal’ ‘rgeos’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-solaris-x86

Version: 0.1.11
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavors: r-devel-windows-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.1.11
Check: examples
Result: ERROR
    Running examples in ‘rGEDI-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: clipLevel1BGeo
    > ### Title: Clip GEDI Full Waveform Geolocations by Coordinates
    > ### Aliases: clipLevel1BGeo
    >
    > ### ** Examples
    >
    > # Specifying the path to GEDI level1B data (zip file)
    > outdir = tempdir()
    > level1B_fp_zip <- system.file("extdata",
    + "GEDI01_B_2019108080338_O01964_T05337_02_003_01_sub.zip",
    + package="rGEDI")
    >
    > # Unzipping GEDI level1B data
    > level1Bpath <- unzip(level1B_fp_zip,exdir = outdir)
    >
    > # Reading GEDI level1B data (h5 file)
    > level1b<-readLevel1B(level1Bpath=level1Bpath)
    >
    > # Extracting GEDI Full Waveform Geolocations
    > level1bGeo<-getLevel1BGeo(level1b)
    
     |
     | | 0%
     |
     |= | 2%Error in self$read_low_level(file_space = self_space_id, mem_space = mem_space_id, :
     HDF5-API Errors:
     error #000: H5T.c in H5Tget_class(): line 1876: not a datatype
     class: HDF5
     major: Invalid arguments to routine
     minor: Inappropriate type
    Calls: getLevel1BGeo ... assign -> [ -> [.H5D -> <Anonymous> -> <Anonymous> -> .Call
    Execution halted
Flavor: r-patched-solaris-x86

Version: 0.1.11
Check: installed package size
Result: NOTE
     installed size is 9.8Mb
     sub-directories of 1Mb or more:
     extdata 2.8Mb
     libs 6.5Mb
Flavors: r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64