CRAN Package Check Results for Package pbdMPI

Last updated on 2021-10-23 05:51:37 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.4-3 16.91 80.06 96.97 WARN
r-devel-linux-x86_64-debian-gcc 0.4-3 13.05 61.62 74.67 WARN
r-devel-linux-x86_64-fedora-clang 0.4-3 142.34 WARN
r-devel-linux-x86_64-fedora-gcc 0.4-3 126.26 WARN
r-devel-windows-x86_64 0.4-3 39.00 109.00 148.00 NOTE
r-devel-windows-x86_64-gcc10-UCRT 0.4-3 NOTE
r-patched-linux-x86_64 0.4-3 16.26 77.96 94.22 WARN
r-patched-solaris-x86 0.4-3 195.00 NOTE
r-release-linux-x86_64 0.4-3 14.42 77.30 91.72 WARN
r-release-macos-arm64 0.4-3 ERROR
r-release-macos-x86_64 0.4-3 ERROR
r-release-windows-ix86+x86_64 0.4-3 46.00 118.00 164.00 NOTE
r-oldrel-macos-x86_64 0.4-3 ERROR
r-oldrel-windows-ix86+x86_64 0.4-3 47.00 118.00 165.00 OK

Check Details

Version: 0.4-3
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:30: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:30: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:30: the top level
     configure.ac:34: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:34: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:34: the top level
     configure.ac:38: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:38: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:38: the top level
     configure.ac:44: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:44: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:44: the top level
     configure.ac:47: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:47: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:47: the top level
     configure.ac:450: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:450: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:450: the top level
     configure.ac:878: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:878: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:878: the top level
     configure.ac:974: warning: AC_OUTPUT should be used without arguments.
     configure.ac:974: You should run autoupdate.
     configure.ac:980: warning: AC_OUTPUT should be used without arguments.
     configure.ac:980: You should run autoupdate.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.4-3
Check: LazyData
Result: NOTE
     'LazyData' is specified without a 'data' directory
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64, r-devel-windows-x86_64-gcc10-UCRT, r-patched-linux-x86_64, r-patched-solaris-x86, r-release-linux-x86_64, r-release-windows-ix86+x86_64

Version: 0.4-3
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:30: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:30: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:30: the top level
     configure.ac:34: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:34: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:34: the top level
     configure.ac:38: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:38: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:38: the top level
     configure.ac:44: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:44: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:44: the top level
     configure.ac:47: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:47: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:47: the top level
     configure.ac:450: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:450: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:450: the top level
     configure.ac:878: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:878: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:878: the top level
     configure.ac:974: warning: AC_OUTPUT should be used without arguments.
     configure.ac:974: You should run autoupdate.
     configure.ac:980: warning: AC_OUTPUT should be used without arguments.
     configure.ac:980: You should run autoupdate.
     configure.ac:30: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:30: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:30: the top level
     configure.ac:34: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:34: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:34: the top level
     configure.ac:38: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:38: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:38: the top level
     configure.ac:44: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:44: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:44: the top level
     configure.ac:47: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:47: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:47: the top level
     configure.ac:450: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:450: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:450: the top level
     configure.ac:878: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:878: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:878: the top level
     configure.ac:974: warning: AC_OUTPUT should be used without arguments.
     configure.ac:974: You should run autoupdate.
     configure.ac:980: warning: AC_OUTPUT should be used without arguments.
     configure.ac:980: You should run autoupdate.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.4-3
Check: package dependencies
Result: NOTE
    Package which this enhances but not available for checking: ‘pbdPROF’
Flavors: r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.4-3
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavors: r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64