CRAN Package Check Results for Package RAMClustR

Last updated on 2021-07-30 07:50:25 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.1 OK
r-devel-linux-x86_64-debian-gcc 1.2.1 12.84 79.50 92.34 OK
r-devel-linux-x86_64-fedora-clang 1.2.1 156.50 NOTE
r-devel-linux-x86_64-fedora-gcc 1.2.1 141.94 NOTE
r-devel-windows-x86_64 1.2.1 18.00 133.00 151.00 OK
r-devel-windows-x86_64-gcc10-UCRT 1.2.1 NOTE
r-patched-linux-x86_64 1.2.1 OK
r-release-linux-x86_64 1.2.1 13.84 99.73 113.57 OK
r-release-macos-arm64 1.2.1 ERROR
r-release-macos-x86_64 1.2.1 ERROR
r-release-windows-ix86+x86_64 1.2.1 36.00 119.00 155.00 OK
r-oldrel-macos-x86_64 1.2.1 ERROR
r-oldrel-windows-ix86+x86_64 1.2.1 21.00 123.00 144.00 OK

Check Details

Version: 1.2.1
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘BiocManager’ ‘stringi’ ‘xml2’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT

Version: 1.2.1
Check: package dependencies
Result: ERROR
    Packages required but not available:
     'InterpretMSSpectrum', 'pcaMethods', 'MSnbase'
    
    Package suggested but not available for checking: ‘xcms’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-macos-arm64

Version: 1.2.1
Check: package dependencies
Result: ERROR
    Package required but not available: ‘InterpretMSSpectrum’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavors: r-release-macos-x86_64, r-oldrel-macos-x86_64