CRAN Package Check Results for Package ProFound

Last updated on 2021-10-21 04:58:41 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.14.1 68.40 93.96 162.36 OK
r-devel-linux-x86_64-debian-gcc 1.14.1 48.72 69.09 117.81 OK
r-devel-linux-x86_64-fedora-clang 1.14.1 241.73 NOTE
r-devel-linux-x86_64-fedora-gcc 1.14.1 201.01 OK
r-devel-windows-x86_64 1.14.1 87.00 137.00 224.00 NOTE
r-devel-windows-x86_64-gcc10-UCRT 1.14.1 ERROR
r-patched-linux-x86_64 1.14.1 61.76 91.92 153.68 OK
r-patched-solaris-x86 1.14.1 209.90 OK
r-release-linux-x86_64 1.14.1 58.06 93.20 151.26 OK
r-release-macos-arm64 1.14.1 NOTE
r-release-macos-x86_64 1.14.1 NOTE
r-release-windows-ix86+x86_64 1.14.1 118.00 155.00 273.00 NOTE
r-oldrel-macos-x86_64 1.14.1 NOTE
r-oldrel-windows-ix86+x86_64 1.14.1 169.00 155.00 324.00 NOTE

Check Details

Version: 1.14.1
Check: installed package size
Result: NOTE
     installed size is 6.4Mb
     sub-directories of 1Mb or more:
     data 1.7Mb
     extdata 1.2Mb
     libs 2.4Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-ix86+x86_64, r-oldrel-macos-x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.14.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'imager'
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 1.14.1
Check: examples
Result: ERROR
    Running examples in 'ProFound-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: profoundChisel
    > ### Title: Noise Chisel Esque Sky
    > ### Aliases: profoundChisel
    >
    > ### ** Examples
    >
    > image=readFITS(system.file("extdata", 'VIKING/mystery_VIKING_Z.fits',
    + package="ProFound"))$imDat
    > magimage(profoundChisel(image)$objects)
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
     - WARNING: imager package not installed, using EBImage gblur smoothing!
    Error: The imager package is needed for smoothing to work. Please install from CRAN.
    Execution halted
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 1.14.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘EBImage’
Flavor: r-release-macos-arm64